This course is designed to work on both PC and Macintosh systems, as well as on mobile and tablet devices. Before you begin, make sure your computer meets these minimum requirements:

Platforms and Operating Systems

This course will work on desktop operating systems currently supported by Microsoft and Apple, iOS devices updated to iOS 6 or later, and Android tablets and phones, including Kindle Fire, that fully support CSS and JavaScript.

Website Browser Requirements

This course will work on all modern browsers that support CSS and JavaScript, including Internet Explorer (version 8 and newer), Chrome, Firefox, and Safari. In all instances, you should use the latest version of these programs if possible for the best experience and the security of your system.

Required Software/Plug-ins

To complete Partners in Time, you will need:

  • An email address where you can send and receive email, and an email program for sending and receiving email (or web browser based email). You will have already used your email address to register for Partner Online Courses.
  • This course does not require the Flash plugin for most browsers, and will work on iOS devices such as the iPad, iPhone, and iPod Touch. Internet Explorer 8 requires the Flash plugin (version 9+) to view video content. Some Internet Explorer 8 users may experience variations in formatting and functionality when viewing video, depending on the version, settings, and installed extensions.
  • Adobe® Reader®. This program can be downloaded FREE from Adobe.com. It allows you to view and print Acrobat .pdf files. You may need an additional app that supports the PDF file format to view those files on your tablet or mobile device – see the App Store for your particular device.
  • A word processing program, such as  Microsoft Word, or Open Office, that supports the .doc and .docx formats to enter information into word processing documents. Mobile and table devices will require an app that supports reading and editing these formats.